IRONCAD Performance Issues After Windows Update

IRONCAD Performance Issues After Windows Update

After a Windows update, IRONCAD performance may become slow or unresponsive.
If you experience these issues, please follow the steps below.

Cause:

The issue may be related to compatibility between the graphics card driver and IRONCAD.

Solution 1: Change the Driver Type

[1] In IRONCAD, go to the [Menu] tab and open [Options].
Under Rendering > Renderer Options > Driver Type, change the [Driver Type].

The following three driver types are available:
  1. OpenGL
  2. OpenGL2
  3. DirectX11
Notes
By default, DirectX11 is selected.
From the dropdown menu, choose a different driver type than the current setting.
Test IRONCAD with all three driver types and select the one that performs best.
Warning
The new settings will not apply to files that are already open.
After changing the driver type, restart IRONCAD and check the performance again.

When selecting OpenGL, the appearance of the TriBall tool will change. For details, please refer to the relevant page.

Solution 2: Update or Perform a Clean Install of the Graphics Driver

If a new driver has been released by the graphics manufacturer, please install it.
Note that driver versions provided by the graphics manufacturer and the PC manufacturer may differ.
We recommend using the latest driver released by the graphics manufacturer (e.g., NVIDIA, AMD).
Notes
In some cases, the latest driver may worsen performance. If this occurs, try using an older driver version.
When installing the driver, select the Clean Install option.
A standard installation may overwrite the existing driver without removing problematic components, and IRONCAD may not return to normal operation.
Warning
After performing a clean install, restart your PC before testing IRONCAD performance.

Solution 3: Uninstall Windows Update

If the issue started after a specific Windows update (such as a driver update), uninstalling that update and reverting to a previous version may resolve the problem.


For Windows 10.

[1] Click the Start menu and select [Settings] (gear symbol).


[2] Select [Update & Security].



[3] Select [View update history].


[4] Select [Uninstall updates].


[5] Right-click the update you want to remove and select [Uninstall].


For Windows 11

[1] Right-click the Start menu and select [Settings].


[2] Select [Windows Update].


[3] Select [Update history].


[4] Select [Uninstall updates].


[5] Select [Uninstall] the update you want to uninstall.


Warning
Uninstalling Windows updates may affect other software.
We cannot guarantee the impact on other applications after removing a Windows update.

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